shardz

- Unnamed repository; edit this file 'description' to name the repository.
git clone git://git.acid.vegas/-c.git
Log | Files | Refs | Archive | README | LICENSE

PKGBUILD (581B)

      1 # Maintainer: acidvegas <acid.vegas@acid.vegas>
      2 
      3 pkgname=shardz
      4 pkgver=1.0.0
      5 pkgrel=1
      6 pkgdesc="Utility that shards the output of any process for distributed processing"
      7 arch=('x86_64' 'i686' 'aarch64' 'armv7h')
      8 url="https://github.com/acidvegas/shardz"
      9 license=('ISC')
     10 depends=('glibc')
     11 source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
     12 sha256sums=('SKIP')
     13 
     14 build() {
     15     cd "$pkgname-$pkgver"
     16     make
     17 }
     18 
     19 package() {
     20     cd "$pkgname-$pkgver"
     21     make DESTDIR="$pkgdir" PREFIX=/usr install
     22     install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
     23 }